Summary
Hosted Exchange Extension (
HEE) shows following exception:
Remoting exception: Exception has been thrown by the target of an invocation
Applies To
MachPanel all versions
Hosted Exchange Extension (
HEE)
Cause
This problem can occurs due to two reasons.
Firstly, when MachPanel remote Server is not installed at Exchange Server i.e. other than the server where MachPanel is
installed. Or it is installed but the MachPanel Provisioning Service is not running.
Secondly, a firewall can block the port 7860 for MachPanel Provisioning Service disabling it to communicate properly.
Solution
Let us consider an example scenario for this which is as under:
Example Scenario
Server1:
Active Directory (AD01)
Server2: Exchange Server 2007 SP1
Server3: MachPanel Control Server
This explanation is for above server setup
scenario.
Case 1: Remote Server not installed or MachPanel Provisioning Service not running
Step1: Install MachPanel Remote Server
You
need to install the MachPanel Remote Server on Exchange server and then configure it
in MachPanel Control Center properly. Here Exchange server is Server2.
Please consult
Exchange installation/configuration guides at:
http://kb.machsol.com/Downloads/6
Note: These settings are for Stand Alone
Exchange Module of MachPanel.
Step2: Setup Active
Directory Domains and Domain Administrator Login:
In your MachPanel Control Center login, Navigate to
Home » Service Director » Active Directory Domains
•
Domain administrator login: This will be the user
responsible for connecting with Active Directory.
• It is
recommended that you create a new user “
administrator2” and call it the
Domain Administrator Login.
Please refer to:
http://kb.machsol.com/KnowledgebaseArticle50017.aspx for creation of
administrator2 login for MachPanel.
Step3: Domain
Administrator Login Permissions:
The Domain User (i.e
administrator2) which is used for
MachPanel should be member of certain groups for Standalone Exchange. For assigning related permissions please see
http://kb.machsol.com/KnowledgebaseArticle50017.aspx
Step4: Configuring Hosted Exchange Extension (HEE)
In MachPanel Provider Control Center (PCC), navigate to:
Home » Service Director » Exchange Hosting »
Server Groups » Edit Exchange Server
Set the following attributes:
- Server alias:
This should be complete server name e.g Exch01.Fabrikam.com.
Complete name of Server2 with Domain Name.
- IP: This
should be IP of Server2. This same IP has to be in
registry of remote server. To ensure this, follow these steps:
- Click Start >> Run
- Type regedit
- navigate to HKEY_LOCAL_MACHINE\SOFTWARE\MachSol\MachPanel
- Ensure that the string RemoteServerPublicIP is set to the same IP address as for Server2. If not, please make it same here
- Server Name: This
should be complete server name like Exch01.Fabrikam.com
Step5: Set MachPanel Remote
Service identity
- Update identity of MachPanel Provisioning Service. i.e. Server2 in this scenario. For this, follow these steps:
- Click Start >> Run
- Type services.msc
- Microsoft Windows Services screen will pop up
- Double Click
on MachPanel Provisioning Service
- Select Log On tab
- Click Browse and
Select the Domain Administrator Login (from Step3) from
Active Directory Users
- Set Password of
user.
Step6
Restart MachPanel Provisioning
Service
- Click Start >> Run
- Type services.msc
- Microsoft Windows Services screen will pop up
- Double Click
on MachPanel Provisioning Service and click Start
Alternatively, you can also start and stop MachPanel Services using Configuration Studio. For example, to start MachPanel Provisioning Service, please open
Configuration Studio and go to
Configure >> Services and click
Start All Services button. Similarly for stopping all services click
Stop All Services button
CASE 2: A Firewall is blocking the port for MachPanel Provisioning Service
A firewall has blocked MachPanel Provisioning Service to communicate appropriately, please disable firewall or allow port 7860 which is used by MachPanel Provisioning Service.